CONTROLE DE VELOCIDADE PWM (PONTE H MOSFET IRF3205) -C/ PIC 12F675 (REF252)

2

Uma forma simples de gerar sinal PWM para fins de controle de motores de tração DC…

Talvez você já tenha visto o uso de motores de corrente contínua (CC) como de limpadores de para-brisas, para movimentar um carro elétrico para crianças. Ou ainda uma adaptação para cadeira de rodas usando 2 destes motores.
Esta proposta de montagem gera justamente o sinal PWM necessário para controlar a velocidade de 2 motores de corrente contínua. Poderá ser útil para suas experiências com este tipo de montagem. Veja o esquema abaixo:

GERADOR_PWM_2M

Temos 2 potenciômetros acoplados entre si (joystick) de modo que o operador possa movimentar para frente ou trás e também para os lados. Estes são tipicamente encontrados em controles de vídeo games, como por exemplo, o Play Station.
Quando ocorre movimentos para os lados e ao mesmo tempo aceleramos para frente ou para trás, teremos valores diferentes de PWM nas saídas para os motores. Em outras palavras, um motor pode estar mais rápido que o outro dependendo do ângulo que se aciona o joystick (movimento em diagonal). Isto permite que se faça curvas para um lado ou outro.

Além das entradas dos potenciômetros temos 3 saídas:
PWM1 – fornece o sinal de controle para o motor 1 de 0 a 100 %
PWM2 – fornece o sinal de controle para o motor 2 de 0 a 100 %
DIR – fornece o sinal que indica movimento para frente ou para trás (direção)

Função Soft:
Esta função permite que não ocorra trancos ao se acionar bruscamente o joystick todo para frente ou para trás. A aceleração será de forma gradativa e de natureza ‘suave’. Se um jumper for colocado no pino 4 com o gnd, esta função será desativada (uso em testes da centralização do joystick apenas). O grau de suavidade pode ser ajustado no arquivo “C” por meio de um ‘define’ sendo necessário depois recompilar para obter o novo hex.
A frequência do PWM gerado está por volta dos 60 Hertz, o que poderá gerar algum zumbido nos motores quando em funcionamento.
Para ilustrar de forma didática apenas, como poderia ser usado este gerador de PWM para tração, veja o esquema abaixo:

PWM_PONTE_H_ 2 M_ IR3205

Suponha que você deseja adaptar motores elétricos a uma cadeira de rodas e criar o necessário para opera-la.
Talvez você decida usar motores de limpadores de para-brisas de caminhão, de 24 Volts de trabalho, facilmente encontrado em autopeças e em desmanches. Então terá que adaptar uma engrenagem ou polia em seu eixo de saída, para acionar uma corrente ou mesmo uma correia dentada, que transmitirá o movimento por meio de outra engrenagem ou polia, de diâmetro maior, fixada na roda. Como é apenas um exemplo, não iremos entrar em detalhes na parte mecânica.
Vamos então analisar um pouco sobre o comando para os motores.
Atualmente é possível obter transistores MOSFET de alta corrente de trabalho entre dreno e supridouro, como o IRF3205, da International Rectifier. Quando devidamente polarizado, permite operar com correntes de até 110 Amperes!
Por isso são muito empregados nas pontes H usadas juntamente com motores de tração DC.
Também encontramos muitos esquemas destas pontes com este componente na internet. Muitos reclamam de montar alguns destes esquemas e logo que funcionam, ocorre a queima dos MOSFETs dos lados superior da ponte H. Isto acontece por erro de polarização. Para que a condução seja plena entre dreno e supridouro, temos que ter uma tensão em torno de 10 Volts entre a gate e o supridouro. Caso isto não aconteça, o transistor trabalhará na zona resistiva dissipando muito calor, levando a sua destruição.
No caso de uma ponte feita somente com MOSFET tipo N, será necessário garantir esta tensão entre gate e supridouro. Existe diversos métodos para isto, mas no esquema acima foi usado um elevador de tensão (step-up) construido com base em um circuito integrado 555, oscilando aproximadamente em 125 khz. Como a tensão de trabalho máxima do 555 é de 18 volts, foi usado a tensão de 12 volts para alimentar esta fonte chaveada elevadora. Na sua saída obtemos 36 volts, mais do que suficiente para fazer conduzir plenamente os MOSFET da parte superior da ponte H. Note que no esquema temos um ‘trimpot’ que permite aumentar ou diminuir esta tensão. Mas ela não poderá ser menor que 10 Volts medido entre gate e supridouro com o transistor conduzindo uma carga.Também não pode ser superior a 20 volts, que é o limite máximo que o transistor suporta com segurança. NOTA: Esta fonte chaveada elevadora de 12 para 36V foi testada em placa de breadboard e funcionou perfeitamente.
Para levar o sinal PWM do pic para a ponte H foi usado optoacopladores 4N25, por ser facilmente encontrado nas lojas de componentes e em sucata eletrônicas. Um par complementar de transistores BC546/556 facilitam a carga e descarga da gate de forma rápida, evitando aquecimentos por chaveamentos. Dependendo da aplicação, podem até ser suprimidos, ficando somente os optoacopladores e os resistores de 10k nas gates. NOTA: Foram feitos testes de condução plena usando os optoacopladores conforme o esquema acima, em placa de breadboard e foi plenamente funcional.
No esquema foi colocado disjuntores térmicos de proteção em caso de curto, um para cada motor e sua respectiva ponte H. O valor de 60 Amperes foi escolhido a título de exemplo, como um provável valor, tendo-se que adequar melhor conforme a corrente do motor efetivamente usado (ex. 125% da corrente máxima do motor). A alimentação vem de 2 baterias automotivas de 12 Volts/60 Amp/h em série. Foram usados alguns reguladores de tensão para obter os 12 Volts e depois os 5 Volts para o PIC.
Os cabos que vão dos MOSFET até os motores tem que ter área de seção compatível com a grande corrente que neles circulará. No caso de usar circuito impresso, as trilhas que ligam o dreno e supridouro devem ser reforçadas com fios estanhados, para possam suportar a grande corrente sem serem destruídas. Os MOSFETs devem ser montados em bons dissipadores térmicos, devidamente isolados e com pasta térmica de boa qualidade.
Obs. Como esta montagem é de carater experimental e didática está sujeita a “bugs” ainda não detectados.
Estão sendo fornecidos os arquivos para que cada hobista possa alterar o programa segundo suas necessidades.

Segue pasta com os arquivos desta montagem:

Pwm_tracao

Manuais:
PIC 12F675
4n25 datasheet
IRF3205 datasheet
LM555 datasheet

Curiosidades:
Minha luta contra a esclerodermia
O que aprendemos dos projetos da natureza
Vivendo e aprendendo
O país da moeda de peso
Do México para o resto do mundo
Alguém tem um lápis?
A atitude faz diferença
Ansiedade

Outros assuntos:
Que tal entender o que foi mal entendido?
Como ser feliz no casamento?
Quando uma amizade se torna íntima demais
Como se livrar do ressentimento

Vídeos:
Será amor ou paixão?
Um novo começo
Como enfrentar o bullying sem partir para a briga
Quem é o Autor da Bíblia?
Será que é amor ou paixão?
Tenha mais paciência
Fale a verdade
Eu me cansei das religiões

Até o próximo artigo!

2

14 comentários sobre “CONTROLE DE VELOCIDADE PWM (PONTE H MOSFET IRF3205) -C/ PIC 12F675 (REF252)

  1. 0

    Cláudio, por gentileza.. Em uma ponte H mais simples, há uma maneira de utilizar apenas uma bateria? Estou testando aqui, mas não estou conseguindo fazer as ligações corretamente. Os motores funcionam PWM normal e variam a velocidade, só que no caso a ré não funciona. Obrigado!

  2. 0

    Caro Larios,tudo bem!

    Primeiramente desculpe fazer comentários aqui,não achei outra solução,porque no outro post ja esta fechado para tal.O assunto é sobre o pedal eletrônico para máquina de costura.

    Pensando em utilizar esse projeto em minha retífica,resolvi montar na protobord para teste.
    Após gravação do pic,acabou-se não tendo resultado;notei que o “led prog” fica aceso com pouco brilho e,apertando a tecla “prog_max,se nota uma pequena oscilação no led,sem resultado na saída para o triac.

    Voltando ao ínicio,consegui o sensor Hall em ponte retirado de uma cabeça de vídeo cassete.Fiz os ajustes para obter as tensões corretas(1,2v limite) nos pinos GP0,GP1,conforme se move o imã.
    Destarte,acredito que não tive problemas com esse e nenhum outro componente ou toda a hardware.

    Enfim,Larios,voçê poderia verificar o softwer se existe algum “bug”,ou se já montou praticamente e obteve resultado concluinte;poderia me orientar na montagem e correções?.

    Atenciosamente:Fernando.

    1. 0

      Olá Fernando!
      Pelo que entendi o Hall está operando a contento. Com o imã que você usou encostado no sensor, no pino 6 do pic você obtém 650 milivolts? E no pino 7, por volta 966 milivolts?
      Você certificou que a fonte está mantendo estável os 5 volts de alimentação?
      O resistor na gate do triac deve ser de valor até 150 ohms. Valores acima podem não disparar.
      Você está usando que triac?
      Esta montagem foi testada em placa de protoboard e funcionou conforme relatado no projeto.
      Tente verificar algum erro sutil. Está Trocado os terminais de saída do sensor Hall nos pinos 6 pelo 7 e 7 pelo 6? O resistor do pino 3 de 680k está realmente ligado no fio da rede correto? O resistor da gate do triac está correto não havendo engano com as cores?
      Por favor verifique e me retorne.

      Cláudio

      1. 0

        Larios tudo bem!

        O único circuito que não montei foi a fonte “fast”.
        Os componentes são todos como indicados no esquema elétrico.
        O sinal de oscilação da rede esta entrando no pino 3.
        Invertendo os polos do imã,as tensões maior/menor(987mv-440mv),também se invertem
        entre os pinos correspondentes 6 e 7.
        Ainda em relação a ponte hall fiz um vídeo pra voçê verificar se o funcionamento é esse
        mesmo e,também outros detalhes que o vídeo mostra.

        Enfim,ainda não obtive resultado positivo.Se precisar de mais detalhes me avise.
        Aqui link do vídeo:
        https://www.youtube.com/watch?v=LRNIc4NmHD0&feature=youtu.be

        Att,Fernando.

        1. 0

          Olá Fernando!
          Gostei muito do vídeo. Notei que ao apertar o botão não acontece nada. Tem algo que pode estar acontecendo. Verifique se não perdeu o byte de calibração do pic. Basta ler o último endereço da flash. Caso tenha valor diferente de algo começando com 0x34xx então foi perdido e não irá funcionar. Se for o caso insira manualmente um valor como 0x34fc. Ou use outro pic virgem para gravar.
          Cláudio

          1. 0

            Larios tudo bem!

            Também gostei do vídeo…rsrs,achei que fica fácil olhando a imagem,do ficar escrevendo “coisas”e imaginando.

            Acredito que não seja o byte de calibração OSCCAL,o gravador lê como voçê me
            explicou,34xx,só muda o final, no caso deste pic 3424,o outro pic 3434.

            E também,já vinha utilizado ele antes em outro projeto de sua altoria,ou seja,
            usei o mesmo pic e funcionou.

            Se não tiver mais nada pra verificar aqui,agora acredito que é com voçê Larios,
            até mais amigo.

            ATT,Fernando.

          2. 0

            Olá Fernando!
            Diante da sua confirmação, resolvi analisar melhor a sua montagem na procura do porque está dando erro. Notei que há uma disparidade com o projeto original.
            Se estou vendo bem, parece que você colocou a carga (lâmpada) no terminal MT1 (que seria o terminal que tem baixa resistência com a gate). No esquema original, a carga fica no MT2 ( o terminal que está ligado a chapa com o furo, ou seja, o terminal do meio). Também o terminal MT1 (que tem baixa resistência com a gate) tem que ficar também ligado aos 5 volts, pois o disparo ocorre quando o pic sai da alta impedância para o nível ‘0’ (circula dos 5 volts para o MT1 e internamente, para a gate, para o resistor de 150 ohms, para o pic, internamente no pic para o gnd). O ideal é que você seguisse de perto o esquema original com a ‘FAST’, e confirmasse o funcionamento, para depois partir para a fonte separada.
            Mas se não quiser, poderá tentar mudar a carga para o terminal central do triac (MT2) e também fazer um jumper do MT1 para o 5 volts do vcc. Note que não haverá isolação, portanto manuseie com cuidado.
            Outra opção para isolar os possíveis choques é colocar um optoacoplador do tipo MOC3020, sendo que o led do MOC será ligado ao 5 volts (pino 1) e o catodo para o pic (pino 2) por meio de um resistor de 1k ao invés de 150 ohms. Sempre com a carga no MT2 (no terminal do meio ligado a chapa de dissipação), puxe um resistor de 2k deste terminal (MT2) ao pino 6 do MOC e do pino 4 para a gate. Desta forma ficará isolado.
            Fico no aguardo…
            Cláudio

  3. 0

    OLA LARIOS , QUEM FALA E MARCOS PAI DA KAROL,, AMIGO VOCE E UMA PESSOA ABENÇOADA,, COMO FOI DITO ANTES VOU FAZER E DOAR ,LITERALMENTE SEM FINS LUCRATIVOS , AMIGO QUANDO ESTIVER EM FUNCIONAMENTO VOU TIRAR FOTOS E ENVIAR A VC ,, VOU PROCURAR OS MOTORES E ADAPDAR , TEM TANTAS PESSOAS QUE PRECISA DE TER PELO MENOS UM POUCO DE LIBERDADE PARA SE LOCOMOVER , COMO EU DISSE E UM ABSURDO CUSTAR TAO CARO, MAS CHEGAMOS LA TEM PESSOAS BOAS AINDA NESSA TERRA E FAZ A DIFERENÇA, E VC E UMA DELAS ,, FORTE ABRAÇO, VOLTAMOS A CONVERSAR ,QUE DEUS TE ABENÇOE

    1. 0

      Larios tudo bem!

      Confesso que cheguei a desconfiar da polarização do triac e não prestei atenção no esquema,erro meu mesmo.

      Estava tão empolgado pra montar que a pressa tirou a minha atenção e,como voçê mesmo disse sobre algo sútil na montagem estar dando errado,tinha razão,era isso mesmo,fez toda a diferença.

      Enfim,o problema estava mesmo na polarização do triac,ou seja,faltou ligar a carga no terminal
      (mt2) e o (mt1) no +5v da alimentação do pic para fluir corrente até o gate e ser disparado pelo pic no pino 5.

      Um outro pequeno detalhe que percebi depois é que o led prog funciona(pisca) com o cátodo no +5v.

      Vou fazer uma pcb só,com a fonte fast e o circuito MCU,depois adaptar dentro de uma sucata de pedaleira pra baixo.
      Bom,Larios,só tenho a agradecer,sem dúvida é uma ótima solução repaginada,durável,expansível,ecônomica…

      Fiz um novo vídeo do funcionamento.
      Aqui link do vídeo:
      https://www.youtube.com/watch?v=T60JGdi2NNc&feature=youtu.be

      Até a próxima amigo Larios,
      ATT,Fernando.

      1. 0

        Olá Fernando!
        Parabéns por seu sucesso na montagem! A persistência é muito importante para alcançarmos os objetivos. Quando ficar pronta a ‘pedaleira’ faça por favor um vídeo e envia o link para nós vermos em pleno funcionamento.
        Obrigado
        Cláudio

        1. 0

          Larios beleza!

          Me desculpa a demora,fiz a placa e todo o resto aos poucos.
          Tive que usar as peças que tinha,por isso algumas diferenças.
          O dissipador sei que não precisa para o proposto;mas quero testar em carga maior.

          Aqui link de vídeo 1:
          https://www.youtube.com/watch?v=7kWtoTVxo-E

          Aqui link de vídeo 2:
          https://www.youtube.com/watch?v=KTMkMC-Wu4w

          Pdf do CI pra quem quiser montar pelo método térmico:
          https://drive.google.com/file/d/0B8yggd7b0SfzWXNBcVpaQk1yT2c/view?usp=sharing

          ————
          Outra pergunta que me surgiu aqui,não relacionada ao projeto,mas por curiosidade mesmo,qual softwer voçê usa pra desenhar os esquemas elétricos postados no blog.

          , att Fernando.

          1. 0

            Olá Fernando!
            Obrigado por enviar os vídeos. Ficou muito legal a sua adaptação. Eu tenho usado o programa PcbExpress (esquemático).
            Cláudio

Deixe uma resposta