controle remoto 8 canais  


0
oi claudio tudo bem,  realizei a montagem do controle remoto de 15 e 8 canais, testei apenas o de 15 e funcionou bem, mas apenas utilizei o arquivo HEX pois estou com problemas em compilar o ASM, pois reporta o seguinte erro (A #DEVICE required before this line 1 Errors,  0 Warnings.)
tentei pelo CCSCcompiler e tive o mesmo erro "erro 128" desculpe o incomodo estou começando a pouco tempo em microcontroladores e gostaria de sua ajuda para resolver esse problema se possível, deste de ja fico grato pela sua ajuda e tenha um bom dia.
 
0

Olá Moretto!

Poderia esclarecer qual artigo se refere? Se possível para a data do artigo ou a ref(xxx).

Obrigado

Cláudio

 
0

obrigado por responder, segue o link da postagem http://blog.larios.tecnologia.ws/iBlog/archives/1332

 
0

Olá Moretto!

Você está usando o MPLAB-IDE para compilar ? O CCS C compiler não funciona com arquivos inteiramente em .asm como os deste artigo. 

Se  você já está usando o MPLAB-IDE, qual a versão dele? Também qual das versões que você tentou compilar e não funcionou? CR_TX_8C_SEL_ASM, e

CR_RX_8C_SEL_ASM, ou CR_8C_PROG_RET_v4, ou CR_8C_SEL_RET_V5_EEPROM_FILES ???

Att.

Cláudio Lários

 
0

oi Claudio tudo bem 

 

      fico muito grato pela sua ajuda, a versão que estou usando é MPLAB X IDE v4.00, em todos os arquivos aparece o mesmo erro, estou mandando o codigo do erro, 

CLEAN SUCCESSFUL (total time: 100ms)

make -f nbproject/Makefile-default.mk SUBPROJECTS= .build-conf

make[1]: Entering directory 'C:/Users/Claudio/Desktop/teste mplab/refer.X'

make  -f nbproject/Makefile-default.mk dist/default/production/refer.X.production.hex

make[2]: Entering directory 'C:/Users/Claudio/Desktop/teste mplab/refer.X'

gnumkdir -p build/default/production 

gnumkdir -p dist/default/production 

"C:\PROGRA~2\PICC\CCSCON.exe"  out="build/default/production"  newfile.c +FM +DF +CC +Y=9 +EA +DF +LN +T +A +M +J +EA +Z -P #__16F628A=1 

C:\Users\Claudio\Desktop\teste mplab\refer.X\newfile.c:0:0:  Error#128  A #DEVICE required before this line

      1 Errors,  0 Warnings.

Build Failed.

nbproject/Makefile-default.mk:111: recipe for target 'build/default/production/newfile.o' failed

make[2]: Leaving directory 'C:/Users/Claudio/Desktop/teste mplab/refer.X'

nbproject/Makefile-default.mk:90: recipe for target '.build-conf' failed

make[1]: Leaving directory 'C:/Users/Claudio/Desktop/teste mplab/refer.X'

make[2]: *** [build/default/production/newfile.o] Error 1

make[1]: *** [.build-conf] Error 2

make: *** [.build-impl] Error 2

nbproject/Makefile-impl.mk:39: recipe for target '.build-impl' failed

 

BUILD FAILED (exit value 2, total time: 1s)

 

 
0

Olá Moreto!

 

O projetinho do controle remoto 8 canais foi compilado usando o MPLAB_ide  versão 8.0.

Eu não tenho a versão MplabX 4.0 mas usei a versão 3.65.

Peguei o arquivo CR27_TX_ASM  e abri o MplabX. Criei um projeto 'teste' e em 'Source Files'  criei um novo arquivo .asm. Copiei e colei o conteúdo de CR27_TX_ASM para este novo arquivo em branco e renomeie ele para teste_rx.asm.

Depois eu fui em 'Production' e cliquei em 'Build Main Project'. Compilou sem mensagens de erro.

 

Será que você não esqueceu de incluir o arquivo asm no projeto?

Veja o anexo  que tem um 'print screen' na tela do MplabX com a compilação realizada com sucesso...

O que você fez se parece com este anexo?

Se não conseguir funcionar , tente entrar em contato com foruns do pessoal da Microchip,  sobre esta versão 4.0. Talvez esteja dando algum problema, não sei.

Att.

Cláudio

 
  
Trabalhando

Por favor Entrar ou Cadastrar